Dashboard Issues

Incident Report for EasyPost

Resolved

This incident is resolved.
Posted Oct 05, 2020 - 15:16 PDT

Monitoring

A fix has been deployed and users can now log into the website and view their dashboard. Engineers continue to monitor.
Posted Oct 05, 2020 - 14:39 PDT

Investigating

We are aware of issues logging in or viewing user settings on the dashboard of the website. Engineers are investigating.
Posted Oct 05, 2020 - 14:28 PDT
This incident affected: Website.