Elevated FedEx Error Rate
Incident Report for EasyPost
Resolved
We have seen no further issues with FedEx and this incident is now resolved.
Posted Feb 09, 2021 - 16:11 PST
Monitoring
FedEx's systems are coming online but are still approximately 50% slower than before the outage. EasyPost engineers continue to monitor the situation.
Posted Feb 09, 2021 - 14:50 PST
Update
We have implemented a mitigation and are no longer experiencing performance issues or errors for non-FedEx requests. FedEx's backend is still experiencing an outage.
Posted Feb 09, 2021 - 14:12 PST
Identified
FedEx is timing out and causing elevated failure rates and poor performance across our API, including shipment and tracker creation. Engineers are implementing mitigations now.
Posted Feb 09, 2021 - 13:56 PST
Investigating
EasyPost is currently receiving an elevated rate of errors from the FedEx backend. Engineers are investigating.
Posted Feb 09, 2021 - 13:06 PST
This incident affected: EasyPost Backend (API, Tracking).