USPS PC Postage System Maintenance

Scheduled for Apr 25, 20:00 - 21:00 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 10, 2026 - 11:43 PDT

Scheduled

We will be performing scheduled maintenance on parts of our infrastructure starting Saturday, April 25th at 8:00 PM PT (11:00 PM ET, Saturday, April 25th). Maintenance is expected to conclude by Saturday, April 25th 8:59 PM PT (Saturday, April 25th at 11:59 PM ET).

During this window, customers may experience increased latency of USPS label purchases.
Posted Apr 10, 2026 - 09:07 PDT
This scheduled maintenance affects: Label Purchases (USPS Postage Purchases).