DHL eCommerce Solutions Carrier Outage

Incident Report for EasyPost

Resolved

This incident has been resolved.
Posted May 19, 2026 - 12:31 PDT

Investigating

EasyPost is currently experiencing issues with all DHL eCommerce Solutions shipment functions due to an outage on their API. We are actively investigating the issue and are in communication with the carrier to resolve it.
Posted May 19, 2026 - 11:49 PDT
This incident affected: Carriers (DHL eCommerce Solutions).