Resolved
This incident is resolved. EasyPost services are fully operational. Any data delayed during the incident has been processed.
Posted Jul 23, 2026 - 15:26 PDT
Update
EasyPost services remain fully operational and system-wide error rates are at normal levels. The tracking and reporting data that was delayed during the incident is continuing to catch up as the backlog clears. We are actively monitoring its progress and will confirm once all delayed data has fully processed.
Thank you for your continued patience.
Posted Jul 23, 2026 - 14:36 PDT
Update
Network connectivity to our data centers has been fully restored, EasyPost services are operating normally, and system-wide error rates have recovered to normal levels. This disruption was caused by a connectivity issue at our hosting provider, which has since been resolved.
EasyPost Engineering will continue to monitor and resolve any effects of the outage. Note that tracking and reporting data may lag due to a backlog of work being processed.
Posted Jul 23, 2026 - 12:21 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 23, 2026 - 11:55 PDT
Update
Carrier services are starting to recover.
Posted Jul 23, 2026 - 11:54 PDT
Monitoring
We are starting to see improved service connectivity in our primary data center. We will continue to monitor and update the status as the situation evolves.
Posted Jul 23, 2026 - 11:29 PDT
Update
EasyPost's hosting provider has notified us that they have identified key network connectivity issues and are hoping to have an update in the next 30 minutes.
In the meantime, EasyPost Engineering continues to work on restoring individual services via our fallback data center. We will update the status in the next 30 minutes -- both to update on our service restoration and the overall networking health of our primary data center.
Posted Jul 23, 2026 - 11:13 PDT
Update
We continue to work on restoring selected EasyPost services via our fallback data center. As we address the most critical services, this should address global error rates in addition to restoring the functionality provided by those services.
Posted Jul 23, 2026 - 11:08 PDT
Update
The ongoing connectivity issue with our hosting provider is still affecting EasyPost services. The provider has confirmed the issue and is actively working to resolve it. During this time, customers may experience errors or failed requests ("service unavailable") when using the EasyPost API and dashboard
While waiting for our hosting provider to restore network connectivity to our services, EasyPost is working on bringing selected services back online via our fallback data center.
Posted Jul 23, 2026 - 10:53 PDT
Identified
The service disruptions affecting EasyPost are caused by an ongoing connectivity issue with our hosting provider. The provider has confirmed the issue and is actively working to resolve it. During this time, customers may experience errors or failed requests ("service unavailable") when using the EasyPost API and dashboard
Because resolution depends on our hosting provider's recovery, we do not yet have an estimated time to restoration. Our team is actively monitoring and will restore full service as soon as connectivity is recovered. We will post another update within 60 minutes, or sooner if the situation changes.
Posted Jul 23, 2026 - 09:37 PDT
Update
We are continuing to engage with our hosting provider as they investigate connectivity issues to our primary data center.
Posted Jul 23, 2026 - 09:27 PDT
Update
We are working with our hosting provider as they investigate connectivity issues to our primary data center.
Posted Jul 23, 2026 - 08:58 PDT
Update
We are continuing to investigate the issue and will continue to update this page as we have additional information.
Posted Jul 23, 2026 - 08:42 PDT
Update
EasyPost is experiencing an internal networking issue that is impacting all operations. We are still investigating.
Posted Jul 23, 2026 - 08:36 PDT
Investigating
We are investigating the root cause of this issue.
Posted Jul 23, 2026 - 07:57 PDT
This incident affected: EasyPost Backend (Webhooks, API, Tracking, Address Verification), Carriers (Asendia USA, Australia Post, Canada Post, DHL eCommerce Solutions, DHL Express, FedEx, FedEx SmartPost, Globegistics, Ontrac, OSM Worldwide, UPS, UPSDAP, UPS SurePost, UPS Mail Innovations, USPS, LSO, Royal Mail, Purolator, DPD UK, CDL Last Mile, Amazon Shipping, Gori, Jitsu, Roadie, UniUni, Veho, Columbus Last Mile, DAI Post, eHub), and Label Purchases (USPS Postage Purchases).