UPS operations are degraded

Incident Report for EasyPost

Resolved

UPS operations have returned to normal.  Some impacted customers may need to re-authenticate their BYOA accounts. See https://support.easypost.com/hc/en-us/articles/26635027512717-UPS-OAuth-2-0-Update#:~:text=Account%20Authorization for more details.
Posted Jul 08, 2026 - 17:43 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 08, 2026 - 13:39 PDT

Identified

UPS operations are degraded due to rate limiting by UPS. We are aware and monitoring the status.
Posted Jul 08, 2026 - 13:38 PDT
This incident affected: Carriers (UPS).