ColumbusLastMile performance issues

Incident Report for EasyPost

Resolved

The CDL performance has returned to normal.
Posted Jun 11, 2025 - 18:05 PDT

Identified

CDL says that Microsoft has identified and released a patch addressing the outage affecting their production servers. They are waiting for the patch to be applied.
Posted Jun 11, 2025 - 16:09 PDT

Investigating

EasyPost is seeing issues with buying labels from ColumbusLastMile. We are investigating and communicating with ColumbusLastMile and will provide updates. We apologize for the inconvenience.
Posted Jun 11, 2025 - 09:03 PDT
This incident affected: Carriers (CDL Last Mile).