Royal Mail International Export Services Outage
Incident Report for EasyPost
Resolved
Royal Mail has started opening up international export services to select locations. Please refer to the carrier's statuspage for more in depth information: https://personal.help.royalmail.com/app/answers/detail/a_id/12556/~/service-update
Posted Jan 24, 2023 - 13:37 PST
Monitoring
Royal Mail is currently experiencing an outage affecting all international export services. This affects all Royal Mail international export services through EasyPost as well. Details of the outage can be found directly at Royal Mail’s website here: https://personal.help.royalmail.com/app/answers/detail/a_id/12556/~/service-update. We will continue to monitor the situation and update when these services are restored.
Posted Jan 13, 2023 - 09:45 PST