Issue Downloading Reports
Incident Report for EasyPost
Resolved
This incident has been resolved.
Posted May 23, 2023 - 09:48 PDT
Monitoring
A fix has been implemented and engineers are monitoring.
Posted May 23, 2023 - 09:34 PDT
Identified
The issue has been identified and a fix is being deployed.
Posted May 23, 2023 - 09:21 PDT
Investigating
Report downloading is currently in a degraded state. Engineers are investigating.
Posted May 23, 2023 - 09:19 PDT