Customers are currently unable to access EasyPost reports due to a database issue. The EasyPost team is actively working to resolve the problem.
Incident Report for EasyPost
Resolved
This incident has been resolved.
Posted Jan 07, 2025 - 16:56 PST
Monitoring
At this time, the EasyPost Reports system is back online, though latest reports may be delayed. The EasyPost team will monitor until all reports have been updated.
Posted Jan 07, 2025 - 16:21 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 07, 2025 - 14:47 PST
This incident affected: EasyPost Backend (API).